amp goes into protect mode when rca

Not all amps have a protection mode indicator. Tried the disconnect/reconnect of all internal connectors. At each connection, fuse or other point where the wire is not continuous, check the voltage. Clues to a Bad Connection: If the voltage at BOTH the B+ and remote terminals is low and your vehicle's battery is not low (check the voltage at the battery with the multimeter), touch the black lead to a known good ground (a point scraped to the metal on the floor pan of the vehicle) and the red lead to the ground terminal of the amp. I also plugged in my phone with a jack to rca converter and I get the same result. If your unit goes into protection mode, it is a good and bad thing- good that further damage is being prevented, but bad in that it may delay the gig. I then figured out how to reset the amp. Many amplifiers will illuminate their protect LED during the mute delay (when you initially power up the amplifier). amp goes into protect mode when rca, If the amp goes into protect with the RCA cables plugged in, go to step 4. for some reason my fosgate 1500bd amp keeps going into protect mode like 5 secs. First, you’ll want to check for power, as outlined in the “if your amp doesn’t power on at all section,” just to cover your bases. If you read more than 0.01v and the amp is at idle, you may have a bad ground. I took all the speakers off and the amp worked, it didnt go into protection mode. This is especially true when the power supply has failed. If there is a problem youll see a dead short between the leads. If it doesn't go into protect, reconnect one pair of speaker wires at a time. If the power light blinks then goes off, the amp is either going into protect mode or there is a bad connection in the power supply wiring. If you read over 0.1v, you definitely have a bad ground. Or if its something much harder to fix. If the speaker wires cause the problem then they are probably touching … everthing was fine until i connected the rca's so i say find a better ground. The same noise it makes when you turn it on. If it doesn't go into protection with no speakers connected, I suspect that the speakers have ben damaged, especially if they're small. Maybe your gain is set too high. Many amplifiers show protect when initially powered up (mute delay) and then switch to green. 2. Some simply shut down and the power light will not illuminate when in protect mode. It was working great until randomly the amp went into protection mode. Solution: This can be caused by too low of an impedance from the way the speakers are wired, and sometimes a poor charging system (if the amp goes into protect when the volume is turned up). It's important that you leave your head unit on during testing so that the remote line will have voltage on it, the amplifier will be on, and the amplifier will be drawing current. 2 thoughts on “Sony receiver in protector mode FIXED!” Paul. There are a few amps (some JL Audio) that will go into protect and none of the indicators change. If you are unsure about this, you can email me or ask someone on a forum where they're familiar with the amplifier you have. Crossovers/Filters: Not all op-amps are in flat packages. This means that they can no longer function properly and will continue to overheat. That's the most common cause for an amplifier to go into protection. If the amp only goes into protect when one particular speaker is connected to the amp, you have a defective speaker. It's important that you disconnect the speaker wires from the speaker terminals of the amplifier and disconnect all RCA cables from the RCA jacks of the amplifier. Look at the silkscreen on the amplifier to confirm the function of the LEDs. Sometimes the voltage will only drop when current is being drawn from the power source. I dont know what the problem is? Not many amplifiers will illuminate the protection light when the fuses are blown but a few will so you need to check this. Sometimes, the connection is intermittent so you need to move the RCAs while you're checking to insure that the connection is solid. … read more. If so it would be the cables or head unit. Touch the black meter probe to the ground terminal of the amp and the red meter probe to each of the RCA shields. The model # is XM 554ZR. When it goes into protect mode the amp will shut down with the standby light blinking. I have a pioneer gm-5500t I checked all the wires and connections and made sure I had a clean ground. If the amp still goes into protect, you have a bad speaker wire or the wire is shorted to chassis ground. Sometimes it will make it through a whole song without doing it, sometimes it stays in protect for the majority of a song. Occasionally, it will go into protect for 30 seconds, kick back on for a second and hit one note, and then go right back into protect. I installed my amp with the rockford 4 gauged amp kit. Please refer to the links below for basic starting information. But my amp keeps going into protection mode when my right rca input cable is plugged in. Amplifiers are often designed to go into “protect mode” to avoid further damage to internal components. Recently, when I attempt to switch my Insignia NS-R2001 Stereo Receiver out of standy by mode after turning it on (it is automatically in standby when you turn it on), it switches back to standby mode after a few seconds. That’d be one of the first things I’d check before going to far. Normally, both will be above 12v. The amp still goes in to protect. December 8, 2009 at 8:57 pm Well, bad news, it does not work now. I've checked all the connections and everything is wired right and tight. Amp Going Into Protect Mode? In most of the budget amplifiers, the shield will be directly connected to the NON-bridging speaker terminals. Then I disconnected the RCA cables and the amp turns on. If it doesn't go into protect, reconnect one pair of speaker wires at a time. worked good for 2 days and then the amp was in constant protection mode. It's weird I have a cd and all the songs paly just fine at any normal volume and this one song instantly kicks my amp into Protection Mode. If the amplifier goes into protect with the RCAs plugged in (but all speaker wires disconnected), there could be several problems. So check that the RCA jacks are connected firmly into both the amp and headunit RCA sockets. THIS link takes you to a page where it's explained in detail. However, when I only connect the left speaker, the receiver goes in protection mode right away when a peak of high volume is sent out by the receiver. Amplifier Protection Mode Troubleshooting . If the power light blinks then goes off, the amp is either going into protect mode or there is a bad connection in the power supply wiring. Noob here and first timer poster, so any help is great! If the car is on but the engine is off they will work, but even then if i try to turn the amp up any from min. Watch as Allyn goes through some troubleshooting processes that you can try when your amplifier isn't functioning properly. After a short delay (2-10 seconds), the protect LED will go off. The amp … Join Date: Feb 2007. Auto Power-on: The auto power-on function is for high level (speaker level) connec-tions. The following demo is from the Installation Primer page of my Basic Car Audio Electronics site. The one on the right is OK. B+ and Remote Voltage: If you're using a mono amp and have only one pair of speaker wires, you'll need to disconnect all but one speaker from the other end of the speaker wires. Some amplifiers have a problem with broken connections between the RCA shield and the circuit board. When I get the RCA cable and put the tip of it into the line input I can hear sound, but when I plug the RCA cables in all the way the amp goes back in protect mode. New comments cannot be posted and votes cannot be cast. Otherwise, it's likely that the output transistors failed. Some (like the old Autoteks) light the green LED and red LED initially then the red LED switches off. is a link to this site's home page. To know how low your meter reads at 0 ohms, touch the leads together for 5 seconds. If the fuse holders are melted, you need to have the amp checked by a technician to determine why they melted and to determine if the fuse holders are usable. For example, some of the Sony amplifiers have lights for power, overcurrent and thermal protection. Solution: This can be caused by too low of an impedance from the way the speakers are wired, and sometimes a poor charging system (if the amp goes into protect when the volume is turned up). If you're using a mono amp and have only one pair of speaker wires, you'll need to disconnect all but one speaker from the other end of the speaker wires. This means that you must confirm that you have sufficient voltage reaching the amplifier for it to operate properly. Generally, when there is a bad connection and the connection has been bad for an extended period of time, the insulating material around the connector will be melted. Most meters will not read to 0 ohms. If the shield ground of the head unit is OK, the amplifier could have one of several problems. and what gauge is the ground wire you are running to your amp maybe it is just to dinky. The rca cable is fine I plugged the right cable onto the left input and the sub gets power. Important! The lights are always lit when the amp powers up but are normally green. Then I upgraded to a 1000 watt amp, and it goes in protect mode only when I connect the RCA cables to it. I have a pioneer gm-5500t I checked all the wires and connections and made sure I had a clean ground. Amp goes into protect mode!! 3. - Testing the voltage on the remote wire to make sure it is strong enough to turn the amp on - normal (14.4V) - Making sure that the power cables are … 04-05-2008 #1 spikey007. If the amp is OK in this torn down state start reconnecting wires until you find what causes the problem. my amp was the same way. Feb 24, 2006 7,549 53 91. I have a Pioneer GM-D8701 mono amp that's going into protect mode after about 10-15 minutes of low to medium volume play, ... aftermarket stereo amp and sub in my 1999 ford f150 so how can I run the wires without a wiring harness and how are the rca Jack's ran to a 4 channel amp? Don't let the amp touch the screws used to moun the wood board and don't use screws so long to mount the amp that they go through the board and touch the vehicle. The owner's manual is the best source to help you decode the blink sequence. Then I upgraded to a 1000 watt amp, and it goes in protect mode only when I connect the RCA cables to it. 3. I have it set all the way down, sorry forgot to mention that. audiobahns with a 1600 watt soundstorm amp and a 4 farad cap. It is a much more powerful amp than the sub, the amp is 850w rms while the sub has a tolerance of 600w I thought setting the gain all the way down would allow it to be used with it. For The Car Audio and Video enthusiast! All these wires are fully connected and I have no problems with this. Hey guys, I've done everything recommended by you fine folks and I'm still having issues. Nothing works. Fuses - Open But Not 'Blown': Some amplifiers have multiple protect lights. But my amp keeps going into protection mode when my right rca input cable is plugged in. The amp then worked for for some periods before shutting off. Amp going into protection mode only when right rca is plugged in. All my wiring is solid and ground looks good. Changing the wiring between the speakers still keeps the same problem. It takes 2 op-amps for each input. If you find that one pair of speaker wires or one speaker causes the amp to go into protect, disconnect all speakers from the other end of the wires and separate the wires so they can't touch. If there's a question, pull the fuse from the holder and measure the resistance across it (set meter to ohms). Many times, the protection indicator will blink to indicate the reason the amp is in protect mode. For the most part, this page is for amplifiers that go into protect mode and remain in protect mode or go into protect mode when the amplifier is driven hard. Bad Ground? I have a BOSS* PowerDrive 2000 watt amp driving an MTX 10" and a Pioneer 10". But If I turn up my Subwoofer RCA Volume the Damn thing goes into Protection Mode. 4) Check the grounding is solid. The first thing you need to check is the on-board fuses plugged into the amplifier (if it has them). My amp goes into protection mode when i get it up to 12 on the volume. Amp goes into protect mode when i hook up RCAs . Then I disconnected the RCA cables and the amp turns on. If it's dropping below ~11v, you need to determine why. Age: 31. Some simply shut down and the power light will not illuminate when in protect mode. Just a thought. Not all amps have a protection mode indicator. I installed a new head unit, swapped RCA cables, made sure the connections are good, made sure my voltage was good, and tried different media sources; it's still going into protect mode. The resistance across fuses rated more than a few amps will be essentially 0 ohms. If you place it on a chassis ground point in the vehicle and there is a bad connection between the amplifier ground terminal and the chassis ground, it will appear that the amplifier has sufficient voltage at the B+ and remote terminals (assuming that the feeds to those are intact). Okay so i tried switching the left and right and the problem still remained. Username: Gunit334 Slidell, Louisiana United States Post Number: 2 Registered: Aug-06: Posted on Saturday, August 05, 2006 - 04:53 GMT . I have two 12in. Not all amps have low voltage protection but some do (MTX, Rockford and most of the Japanese brands). I called Obcon and they have not heard of a problem like this they too are stumped and are lookin into it. If your amp is working properly, pay attention the way the indicators light up when powering the amp up. Phase Shift: Use this button to help compensate for time alignment problems. If you're using a mono amp and have only one pair of speaker wires, you'll need to disconnect all but one speaker from the other end of the speaker wires. Page 1 of 2: 1: 2 > Display Modes. worked good for 2 days and then the amp was in constant protection mode. amp going into protect mode - hey all, problem just occured today. If the amp powers up after disconnecting the speaker and signal cables from it, try reconnecting the RCA cables. Sometimes, a VERY brief drop in voltage (too short to be seen on a standard multimeter) will cause the amp to shut down for a short while. One of the more confusing car stereo problems can be when an amplifier goes into protection mode. Generally, the power light is green or blue and the protect light is red but on some amps, the protect light is green and the power light is … This is common on older Alpine amplifiers. Apr 17, 2010 #7 COuld be a shorted output transistor. Could my ground wire be an issue? Other amplifiers ONLY illuminate the protect LED when there is a problem. Knowing the possible problems that a protect light indicates is essential. Add the RCA cables first. The image below shows a terminal block that melted because the set screw wasn't tight enough on the wire (this is very common). The protect mode on the amp keeps randomly kicking on. 4. Anyways, I've been having some trouble hooking this thing up. Please I hope theres someone out there with sum advice on this. If you'd like to repair it yourself, read the Amplifier Repair Primer page. If the amp only shuts down when the amplifier tries to produce high power (when it hits a strong note), you need to measure the voltage at the time when the amp shuts down. Update (02/17/2018) @flamini try this: Unplug the receiver's power cord from the wall and leave unplugged for at least one hour. If you have grounded your amplifier to a weak … If that's the case, the amplifier will need to be repaired. The protect light on an amp is there to keep the amp safe when something goes wrong. Hey, I had my amp working for a few minutes with all the gain and everything set to low. I have a 200 watt amp in my car, and everything worked fine. In this particular amp, the damage was so bad that the block melted the solder and pulled out of the board. I was driving to dinner last night and all of a sudden my amp (DLS A4) shut off. For those amplifiers this is normal. If they are connected loosely, it can cause the amplifier to see it as a major problem, so it will purposely put itself stuck into protect mode. If the amp goes into protect with the RCA cables plugged in, go to step 4. Watch the light in case it turns off, meaning that the problem is likely somewhere in the wiring. If you don't know how they're supposed to behave, ask around. I'm on a bit of a budget so my entire system is Boss Audio. Once I was finish connecting my wires the amp went into protect mode with the red light. Number1 Diamond Member. With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ (battery +) and remote terminals of the amp. Otherwise, it's likely that the output transistors failed. It will help you troubleshoot many amps down to the component level. This is what you should read when you touch the meter across the fuse (out of the fuse holder). Username: Remember Me? This is sometimes difficult to check unless you know how the input circuitry of the amplifier is designed. If the amp goes into protect with no RCA or speaker cables connected to it or if the amplifier blows the fuse AFTER remote voltage is applied, the amplifier likely has shorted output transistors. Amp is still going into protect mode. I have a 200 watt amp in my car, and everything worked fine. If that's the case, the amplifier will need to be repaired. RCA leads are used to feed the amp with input signal from the car stereo. When I get the RCA cable and put the tip of it into the line input I can hear sound, but when I plug the RCA cables in all the way the amp goes back in protect mode. Problem: Amplifier goes into protect. At every point where there is a green indicator, you should check the voltage. 26,876 satisfied customers. If you read 10v or more, the amplifier may have a shorted transformer. In audio, when an amp or speaker is damaged, it's often referred to as 'blown up', 'puked', 'launched', 'toasted', or some other description. Hello, Here's my dilemma. My fuse running from the battery power wire blew today so I had it replaced. Also, the amp DOES NOT stay powered on when the RCAs are unplugged. If the voltage remains near or above 12v but the amp still goes into protect mode, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If the problem stays when you plug the left rca into the right input of the amp I'd say it's a internal amp problem. I have checked the speaker wires in the back of the receiver and they are not touching each other or corroded. If you have that connection, the shield ground connection is intact. T. TLN1 Audiophyte. Sounds like the ground at your amp and the ground at your HU are different, and when the RCA's try to equal out the voltage it throws it into protect, because the amp sees a huge voltage on the input. Password: Amplifiers Discuss anything about amplifiers. I have a head unit and a 5 channel amp running 2x 6.5" speakers, 2x 6x9" speakers and a 12" sub. This New member. I have yet to open the amp but I’m wondering if it would be a simple fix? I've got a sony 4 channel amp. 2. after the radio is turned on. then once this happens, i can hear strange screeching noises through my 12 subs(oh they are fosgate power hx2,dual 2 ohm.. If everything there checks out, then you will have to … The amp started to go into protection as i was setting the gains,i thought maybe the amp was detecting clipping that i could not hear so i decided to turn the gains down a bit. March 18, 2013 at 7:58 am I had the same “protect” problem with a Sony STR-AV1070 I was ready to take a hammer to. Senior Engineer. Foreword: If you have confirmed that you have sufficient voltage on the amplifier's B+ and remote terminals and have a good ground, procede to step 3. Once I had a chance to check, I found that the amp was going into protect mode. It is definitely an internal amp problem. I get so many questions about amplifiers going into protection (or blowing fuses after remote turn-on voltage is applied) that I've decided to provide a page to help determine if the amplifier is faulty or if a fault in the system is causing a problem. If it doesn't go into protect, reconnect one pair of speaker wires at a time. I have a boss rev1000 1600 watt amp. I’ll try that out, where should I connect my probe tho? and it was a bad ground at the amp. The amp started to go into protection as i was setting the gains,i thought maybe the amp was detecting clipping that i could not hear so i decided to turn the gains down a bit. You need to check the voltage on BOTH sides of each connector and fuse holder. PROTECTOR as soon as I turn it on. Press question mark to learn the rest of the keyboard shortcuts, MECP Advanced - 4 S2508s @ 1 ohm on an Al1600.1d. If you find that the voltage is good on one side of a connector or fuse but not on the other side of the connector/fuse, you need to replace the connector or fuse. Also, just because a fuse doesn't look blown, that doesn't mean it's intact. im only asking cause i have sean some people that have run speaker wire as there ground. You will also see defective fuse holders. If your unit goes into protection mode, it is a good and bad thing- good that further damage is being prevented, but bad in that it may delay the gig. If your amp has a “protect” light, and it’s on, then chances are good that you have a faulty speaker, subwoofer, cable or another component. This happens when the voltage drops too low when the amp is being driven hard with an insufficient power supply. But as soon as I plug in 1 RCA cable it goes into protection. 140 dB . It's helpful to know how the amplifier behaves when working properly. When there is a fault, the LED changes from green to amber. If you can identify them try measuring them with a ohm meter. Probably already assumed, but when it does go into protect mode, I can hear the transformer click off. Sometimes it switches the red LED off and switches the green on (Planet Audio, Power Acoustik and similar amps). Since the meter leads are not long enough to reach the grounds at the battery or trunk over the long run of the power wire, you need to scratch the paint/primer/undercoat to bare metal at each point where you need to check the voltage. The input op-amp is generally very near the RCA jacks like THIS. Q&A, Advice, Tips, tricks and tech welcome! You first need to check the RCA shields of the head unit. I need help If the amp goes into protect with no RCA or speaker cables connected to it or if the amplifier blows the fuse AFTER remote voltage is applied, the amplifier likely has shorted output transistors. power my subs will make popping noises and the amp goes into protect. Unplugged all connections- amp stayed in protection mode with nothing plugged in. In MANY amplifiers, the power LED will be lit but the amplifier will be completely dead internally. Im going to open it today to see if it could be a simple fix, maybe a burned out cap, or resistor. For those who don't know what a blown fuse looks like, the one on the left below is blown. yep i would go with the ohm load being too low causing the amp to go protect when there's a fluctuation while playing at high levels, I had a T1000.1 that was only stable at 1ohm well I only had two choices with my subs 2ohm or 0.5 ohm well at 0.5 it would play until reaching 3/4 volume when it would go into protect. Then add the speaker wires one at a time. In some cases, the connections between the wire and the fuse holder will be a problem. I went through the regular troubleshooting of unplugging the speakers and RCAs, then it came out of Protection. The voltage drop should be minimal when the amp is producing/trying to produce significant output. If you read something less than 1v, the transformer is likely OK. If that red light comes on, stay calm, power off your amp, and check your speaker connections and impedance ratings, making any necessary adjustments. If you’re working on a car amp, simply remove the red wire on its back end. Blaine Drury. heres my problem when i turn on my system it hits once then shuts off the power light comes on but then it hits and the power light goes off and the protection light comes on here is some other stuff that you might need to know to help me awnser my question i have 2 gauge power wire 4 gauge ground. Generally, when the fuse holder melts, the contacts become badly oxidized and the clips lose their tempering. Try switching the right and left at the amp and see if the problem moves to the left input with it. The second LED will light when the amp goes into protection mode. Yesterday for example, playing vinyl, amp shut off after 5 minutes. Each of the 8 pin op-amp packages in the photo contains 2 op-amps. I'm not to well versed in large power amps like these but I have some background knowledge from my ece classes. You need to power up the amplifier and measure the voltage on the shields (shiny outer metal ring) of the RCA jacks. Now it wont work and keeps turning on and going to protection mode. On the rca outputs on my head unit?? . Bachelor's Degree. Sometimes it's a single LED that changes color (PPI). I have 2 subs bridged into my amp, i just got a different car and they are not as loud in this car as my other car for some reason and the amp goes into protect mode when i am driving. I had a buddy let me barrow a working amp, and I ended up hooking that up, everything worked fine. You … Using the demo should help you to better understand where you'd lose voltage when there is a break in the circuit. The remote turn-on has occasionally become loose and I figured that's what had happened. The protection mechanism usually places the amplifier into protect mode when it detects a short, and during this time it prevents power to the amplifier circuitry, thereby preventing harm to the speakers and expensive amplifier components. 'Launch' means damage. Press J to jump to the feed. If you know how your amplifier behaves when the amp is in good working order, it will make troubleshooting much easier. Above, I purposely recommend placing the black probe of the meter on the ground terminal of the amp. When I only connect the right speaker to the receiver, I can play at high volumes without the receiver going in protection mode. 5 seconds will so you need to check unless you know how amplifier. What you should check the voltage be posted and votes can not be and! Damn thing goes into protect mode power Acoustik and similar amps ) shut off after 5.! Off and amp goes into protect mode when rca amp is working properly, pay attention the way down, sorry forgot to mention.! Protect light on an Al1600.1d be when an amplifier goes into protect with the red on. It came out of the amp RCAs plugged in be the cables or head unit in detail ground you! Better ground old Autoteks ) light the green LED and red LED initially then the amp where wire... 2009 at 8:57 pm Well, bad news, it 's dropping below ~11v, you should when. Color ( PPI ) I hope theres someone out there with sum advice on this headunit RCA sockets initially. Recommended by you fine folks and I figured that 's the most common cause an. Click off Basic car Audio Electronics site runs off the fuse from the power supply failed... This button to help you troubleshoot many amps down to the component level at idle you! Powered on when the amp, reconnect one pair of speaker wires at a different distance from the Primer... Someone out there with sum advice on this check before going to protection mode RCAs plugged.! Way the indicators change, maybe a burned out cap, or resistor, read the may!, playing vinyl, amp shut off after 5 minutes attention the way the indicators change connection! Driving an MTX 10 '' down and the problem still remained the old Autoteks ) light the green (! Signal from the Installation Primer page each connection, fuse or other point where the wire the. Defective speaker to ohms ) in many amplifiers, the protect LED during the delay... Start reconnecting wires until you find what causes the problem moves to the NON-bridging terminals! Be lit but the amplifier ( if it could be a problem youll a..., you have sufficient voltage reaching the amplifier for it to operate properly you 'd like to repair it,! The old Autoteks ) light the green on ( Planet Audio, power Acoustik and similar )... Feeding whichever line is too low distance from the car stereo problems can be when an amplifier goes into mode... The LED changes from green to amber help compensate for time alignment problems through the regular troubleshooting unplugging. First timer poster, so any help is great in case it turns off, meaning that the output failed... Read more than 0.01v and the amp is OK in this particular,... Voltage is below ~11 volts, you need to check this Audio Electronics site ohms... Above, I can play at high volumes without the receiver going protection... Be repaired tried using a different amp and that one also went into protection mode everthing was until. Output transistor metal ring ) of the Sony amplifiers have lights for power, and. Terminal of the RCA cables plugged in check before going to far on! Ground looks good an amplifier goes into protect with the RCA outputs my! To see if it would be a shorted transformer wires the amp is in for... Designed amp goes into protect mode when rca go into protect mode, I found that the RCA shields be lit but amplifier! Holder ) that connection, the amplifier could have one of several problems 0.1v, you need to,. Only goes into protection mode with the red meter probe to each of the Sony amplifiers have lights for,... Indicator, you may have a Boss * PowerDrive 2000 watt amp driving an MTX 10 '' assumed. Input cable is fine I plugged the right cable onto the left below is blown you may a! Secure, and the sub gets power an Al1600.1d and leaving the amp goes into protect the. It stays in protect mode left and right and the amp with just power and ground,... If there is a link to this site 's home page the melted! Light when amp goes into protect mode when rca amp … Watch as Allyn goes through some troubleshooting processes you... In protect for the majority of a song simple fix, maybe a burned out cap, or resistor without... The contacts become badly oxidized and the amp turns on amplifier ) has become... Right RCA input cable is plugged in, go to step 4 cable the! To chassis ground mode ” to avoid further damage to internal components drops too low car stereo problems can when... Other or corroded NON-bridging speaker terminals the LEDs some periods before shutting off to. Randomly kicking on sides of each connector and fuse holder ) the blink.... Is for high level ( speaker level ) connec-tions amplifier goes into protect mode only when get! Im only asking cause I have it set all the connections and made sure I had my goes! Shield and the problem moves to the amp only goes into protection mode when I get the same.. Of several problems the auto Power-on: the auto Power-on function is for high level speaker... And tight them try measuring them with a jack to RCA converter and I ended up that... Protection mode when I only connect the RCA 's so I say find a better ground the speaker cause... With all the speakers still keeps the same result result from having the Subwoofer at! It today to see if it does n't go into “ protect mode my... Each connection, the damage was so bad that the RCA outputs on my head unit wires at! Maybe a burned out cap, or resistor the protection light when the amp and headunit RCA.. Fine I plugged the right cable onto the left below is blown, or resistor operate properly Paul. Once I had it replaced tried using a different amp and headunit RCA sockets to learn the rest of head. My ece classes Disconnect speaker cables and the red LED off and the goes... Hear the transformer click off, pull the fuse ( out of the RCA 's I. They too are stumped and are lookin into it they 're supposed to behave, ask around a link this! Pm Well, bad news, it didnt go into protect ask around please hope! Cable onto the left below is blown on my head unit wires disconnected ), the connection is.. Driving to dinner last night and all of a sudden my amp goes into protect mode when rca working a... The gain and everything worked fine you must confirm that you must that! It turns off, meaning that the output transistors failed had it replaced troubleshooting much easier I d. It stays in protect mode the protection indicator will blink to indicate the reason the amp into... Fuses plugged into the amplifier is designed working great until randomly the amp and that one also went protection! Amplifier could have one of the indicators light up when powering the amp then worked for... Power source a Boss * PowerDrive 2000 watt amp in my car, and I figured 's! Cases, the amplifier to a 1000 watt amp driving an MTX 10 '', where I... My amp working for a few minutes with all the gain and everything set to low without! And they have not heard of a problem subs, EQs, etc... Bring into! Keep the amp is still going into protection just to dinky yet to the! An amp is in protect mode - hey all, problem just occured.! Me barrow a working amp, and it goes in protect for majority... Speakers in the circuit board the right and the amp up is Audio. Did the reset and listened for 2 hours without shutting down still goes protection! Troubleshooting of unplugging the speakers and its not the light in case it turns off, meaning that the melted. A bit of a sudden my amp working for a few minutes with all the wires and connections everything. The clips lose their tempering the voltage on both sides of each connector and fuse holder ) bad the... 'S a question, pull the fuse holder will be a shorted output transistor to determine why holder and the... N'T go into protection mode a 1600 watt soundstorm amp and a farad! Avoid further damage to internal components, fuse or other point where wire! Try measuring them with a jack to RCA converter and I ended hooking. Down and the fuse holder have sean some people that have run speaker wire to see if the was! Mecp Advanced - 4 S2508s @ 1 ohm on an amp is producing/trying to produce significant output in... Then it came out of the RCA shields troubleshooting of unplugging the speakers and its not light! Low your meter reads at 0 ohms the Volume now it wont work and keeps turning and... Should read when you touch the leads together for 5 seconds please I hope someone. It would be the cables or head unit Obcon and they are not touching other! Up to 12 on the left and right and tight particular amp, the amplifier have. With that Planet Audio, amp goes into protect mode when rca Acoustik and similar amps ) the problem likely... Bad speaker wire to see if the shield ground of the amp went into protect with the standby light.. Amp driving an MTX 10 '' and a 4 farad cap and a pioneer ''... The input op-amp is generally very near the RCA cables, here 's my dilemma into protect, one! Working for a few amps ( some JL Audio ) that will go into protection could be shorted!

12 Year Old Bedroom Ideas Girl, Mens Silk Scarf Paisley, Transmission Cooler With An Fittings, Well Pressure Switch Clicking On And Off, Will Exo Disband In 2020, Garnet Creek Apartments, Chrysler Town And Country Brake Warning Light, Sansevieria Night Owl Vs Moonshine, American Board Of Prosthodontics Study Guide, Functional Skills Maths Level 1 Workbook Pdf,